PHP 5.1.2 al repositori Ubuntu Server 6.06

El repositori d’Ubuntu Server ha alliberat la versió 5.1.2 de PHP per al repositori d’Ubuntu Server 6.06 dapper.
php5_5.1.2-1ubuntu3.10_all.deb

Per a màquines de desenvolupament amb 7.10 feisty han alliberat la versió 5.2.3 de PHP.
php5_5.2.3-1ubuntu6.1_all.deb

Les novetats de la 5.1.2 anunciades el gener del 2006 són:

Seguretat:

  • HTTP Response Splitting has been addressed in ext/session and in the header() function. Header() can no longer be used to send multiple response headers in a single call.
  • Format string vulnerability in ext/mysqli.
  • Possible cross-site scripting problems in certain error conditions.

Novetats:

  • Hash extension was added to core and is now enabled by default. This extension provides support for most common hashing algorithms without reliance on 3rd party libraries.
  • XMLWriter was added and enabled by default.
  • New OCI8 extension that includes numerous fixes.
  • PNG compression support added to the GD extension.
  • Added –enable-gcov configure option to enable C-level code coverage.
  • getNamespaces() and getDocNamespaces() methods added to SimpleXML extension.

Sol·lució d’errors:

  • Correction of the many regressions in the strtotime() function.
  • Fixes of several crashes, leaks and memory corruptions found in the imap, pdo, gd, mysqli, mcrypt and soap extensions.
  • Corrected problems with the usage of SSI and virtual() in the Apache2 SAPI.
  • Build fixes for iconv and sybase_ct extensions.
  • Fixed the previously broken Sun(rise|set) functions.
  • SQLite libraries upgraded to 2.8.17 and 3.2.8
  • Win32 binaries now include libxml2-2.6.22 and libxslt-1.1.15.

El proper cop que feu als vostres servidors dapper un apt-get upgrade tindreu aquesta versió de PHP instal·lada.

 
Comments